Thursday, March 19, 2015

Hi Everyone at last,
The internet here has been so so slow I haven't been able to load my own blog page to post even some text! only speed available to me is 47kbs, that is same speed as at the beginning of dial up internet years ago.
Had done most of the work on the boat and moved off the dock to a mooring in the lagoon to make sure everything was good to go when I found 1 battery had failed. So had to fix that as well before leaving. Then I had only the brand new burners for the stove to fit, and, with that finished I was able to cook again on board. These new ones are made in Germany, and as always spot on in quality.
BUT
Monday teatime whilst making my dinner I had a bad bad fire on the stove! the right hand side burner had been turned down cos the rice was nearly cooked, after some minutes I hadn't noticed that the flame had gone out, the paraffin had ceased vaporizing and was now still coming out as a liquid,  as I removed the rice pan to put the rice on my plate there was a whooshing sound and sudden heat, some how this paraffin had got into the other pan with the oil in and my drum sticks, the whole stove top was also alight with searing heat with the oil now ignited too. After what seemed an age I finally got it under control, not a minute too soon as the fire was so intense, there has been serious charring of some wood and a lot of smoke damage. I now have had to come back into the marina to fix this mess cos I won't be able to do it otherwise.
This has never happened before in the 20 odd years on this boat!!

I have a feeling by the time I do get it fixed it will be to late to get to Antigua this year.
I am now alongside again! and as of this minute as I write I have internet again
Will advise how this goes and whether or not I can make the classics.
Roy

No comments:

Post a Comment